EpiCenter

Laptop Specifications

If you are trying to use Epic on a home or personal laptop, then your machine will need to meet these minimum requirements in order for Epic to function properly.

Windows Citrix Web plug-in , version 11.2 or higher:

Mac Citrix plug-I, version 11.0 or higher:

PLEASE NOTE:  Mac OS versions released before 2007 (10.4 Tiger and lower) are NOT supported for remote access.  If you have one of these older operating systems, please upgrade software (and hardware, if needed) to a more recent version.